Ihr Warenkorb : 0 Artikel
Betrag : 0,00 €
Ihr Warenkorb ist leer!
Produkt update
Coupon
add
AJAX loader
Coupon code invalid! Please re-enter!
checkout
Anmelden Registrieren

Zugangsdaten eingeben

Username *
Passwort *
Zugangsdaten lokal speichern!

Neu registrieren

Felder mit (*) müssen ausgefüllt werden.
Name *
Username *
Passwort *
Passwort wiederholen *
Email *
Email wiederholen *
Captcha *
Reload Captcha

Häufige Fragen - Alle Fragen

Bitte wählen Sie eine Kategorie

Alle Fragen ansehen
Wen nervt es nicht, wenn der Captcha ausgetrickst wird und Anmeldungen erfolgen, mit dem Ziel Spam zu versenden. Zumeist sind es Andressen aus dem chinesischen und russischen Raum. Da im Backend von Joomla die IP-Adresse mit protokolliert wird kann man sehr leicht rausfinden woher die Domain und die IP-Adresse ist. Hier ein Link zu https://centralops.net/co/. Anhand der Informationen kann man das Herkunftland bestimmen. Und wenn man auf den Traffic der Länder verzichten kann, sollte man zusehen, das dies unterbunden wird.
es ist möglich in der .htaccess Datei einen Eintag wie folgt zu machen.
## Begin - GeoIP-Bocking
SetEnvIf GEOIP_COUNTRY_CODE CN BlockCountry
SetEnvIf GEOIP_COUNTRY_CODE RU BlockCountry
SetEnvIf GEOIP_COUNTRY_CODE PL BlockCountry
SetEnvIf GEOIP_COUNTRY_CODE PA BlockCountry
Deny from env=BlockCountry
## End - GeoIP-Bocking
Damit unterbindet man das sich IPs aus den Ländern auf der Seite verirren. Es ist ein Allheilmittel, aber......
Eine andere Möglichkeit ist das Weiterleiten, wie folgt:
## Begin - GeoIP-Weiterleitung
RewriteCond %{ENV:GEOIP_COUNTRY_CODE} ^(RU|CN|PL|PA)$
RewriteRule ^(.*)$ http://www.disney.com/$1 [L]
## End - GeoIP-Weiterleitung
Login als root, Verzeichnis wie folgt erstellen
mkdir /root/Downloads/spam und in das Verzeichnis wechseln und dann folgendes eingeben.
yum -y install ipset wget

wget http://www.ipdeny.com/ipblocks/data/countries/cn.zone
wget http://www.ipdeny.com/ipblocks/data/countries/ru.zone

ipset -N china hash:net
ipset -N russia hash:net

for i in $(cat /root/Downloads/spam/cn.zone ); do ipset -A china $i; done
for i in $(cat /root/Downloads/spam/ru.zone ); do ipset -A russia $i; done

firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set china src -p tcp --dport 443 -j DROP
firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set china src -p tcp --dport 80 -j DROP
firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set russia src -p tcp --dport 80 -j DROP
firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set russia src -p tcp --dport 443 -j DROP
firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set china src -p tcp --dport 21 -j DROP
firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set china src -p tcp --dport 22 -j DROP
firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set russia src -p tcp --dport 21 -j DROP
firewall-cmd --direct --add-rule ipv4 filter INPUT 0  -m set --match-set russia src -p tcp --dport 22 -j DROP
firewall-cmd --reload
Mit diesen Befehlen haben wir die IPAdressen geladen in eine Blacklist geschrieben.
Und die einzelnen Dienste http / https / ftp / ssh gesperrt.

Nach langem Warten ist der Packet Tracer 7 auch für Linux verfügbar. Und es werden, wie auch bei der Version 6.2 veraltete Crypto-Bibliotheken vorausgesetzt.

Nach einer Registrierung unter https://www.netacad.com/about-networking-academy/packet-tracer/hat man dann die Möglichkeit den Packet Tracer zu downloaden.

Entpackt das Paket und führt die Installation als root aus. Das Installations-Verzeichnist ist dann /opt/pt/ . Nach einem Start per ./packettracer aus dem Verzeichnis heraus sieht man folgendes.....und es passiert nichts.

# ./packettracer
Starting Packet Tracer 7.0

Solltet Ihr es als root ausgeführt haben gut, ansonsten wieder als root anmelden.

gebt folgendes ein und verfolgt die Ausgabe:

# ldd /opt/pt/bin/PacketTracer7
    linux-vdso.so.1 =>  (0x00007ffd1f355000)
    libcrypto.so.1.0.0 => not found
    libQtWebKit.so.4 => /lib64/libQtWebKit.so.4 (0x00007f90f0b43000)

Ein Symlink im Verzeichnis /lib64 bringt nichts,

# ldd /opt/pt/bin/PacketTracer7
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /opt/pt7/bin/PacketTracer7)
    linux-vdso.so.1 =>  (0x00007fff81d40000)
    libcrypto.so.1.0.0 => /lib64/libcrypto.so.1.0.0(0x00007f1f200c4000)                                                                                                                                             

also die Holzhammermethode.

Im Webbroser folgende Adresse aufrufen https://pkgs.org/centos-6/ghettoforge-plus-x86_64/openssl-1.0.0-27.z.2.ec1.gf.el6.x86_64.rpm.html

Dieses Paket downloaden und nicht installieren nur auspacken und folgende Dateien ins Verzeichnis /lib64 kopieren

libcrypto.so.1.0.0 und libssl.so.1.0.0

Ein nochmaliger Aufruf zeigt dann folgendes:

# ldd /opt/pt/bin/PacketTracer7
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /opt/pt7/bin/PacketTracer7)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libQtNetwork.so.4)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libQtNetwork.so.4)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libssl.so.10)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libssl.so.10)
    linux-vdso.so.1 =>  (0x00007ffcccebc000)
    libcrypto.so.1.0.0 => /lib64/libcrypto.so.1.0.0 (0x00007f2cd5732000)

Das passt jetzt.

# ./packettracer

startet jetzt den Packet Tracer 7 unter Linux.

 

After a long wait the Packet Tracer 7 is also available for Linux . And there are , as provided 6.2 obsolete crypto libraries and in the version .
 
After registering at https://www.netacad.com/about-networking-academy/packet-tracer you then have the option to download the Packet Tracer .

Unzip the package and install it as root . The installation is then Verzeichnist /opt/pt/ . After a start in my ./packettracer from the directory you can see the following ..... and nothing happens .
 
# ./packettracer
Starting Packet Tracer 7.0
 
Should you have it as root run well , otherwise log back in as root .
give the following and pursuing the issue

# ldd /opt/pt/bin/PacketTracer7
    linux-vdso.so.1 =>  (0x00007ffd1f355000)
    libcrypto.so.1.0.0 => not found
    libQtWebKit.so.4 => /lib64/libQtWebKit.so.4 (0x00007f90f0b43000)
 
A symlink in the /lib64 is useless

# ldd /opt/pt/bin/PacketTracer7
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /opt/pt7/bin/PacketTracer7)
    linux-vdso.so.1 =>  (0x00007fff81d40000)
    libcrypto.so.1.0.0 => /lib64/libcrypto.so.1.0.0(0x00007f1f200c4000)  
 
So the sledgehammer approach .
In Webbroser following address call
 
 
Download this package not install and unpack the following files into /lib64 Copy
libcrypto.so.1.0.0 and libssl.so.1.0.0
 
A repeat call is then as follows :
 
# ldd /opt/pt/bin/PacketTracer7
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /opt/pt7/bin/PacketTracer7)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libQtNetwork.so.4)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libQtNetwork.so.4)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libssl.so.10)
/opt/pt7/bin/PacketTracer7: /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libssl.so.10)
    linux-vdso.so.1 =>  (0x00007ffcccebc000)
    libcrypto.so.1.0.0 => /lib64/libcrypto.so.1.0.0 (0x00007f2cd5732000)
 
This fits now .
 
# ./packettracer
now starts the Packet Tracer 7 on Linux .